Navigation

Pligg Support

Dear Pligg Developers,

Do you have a timeline on when we can expect the stable release of Pligg 2.0?

Thanks!
This release addresses a number of issues related to using Pligg in a language other than English. We have tested and bug fixed both the installation process and user language selection feature.
The installation and upgrade script are no longer dependent on the pligg.com server for installation language files. An added benefit is that the upgrade process now performs much faster.

The Simple Messaging module and story comment permalinks are other major fixes included in this release.

https://github.com/Pligg/pligg-cms/releases
3 files have been edited.

/kmessaging/class.KMessaging_v1.2.3.php
/templates/user_navigation.tpl
simple_messaging_main.php

### class.KMessaging_v1.2.3.php
replaced the word "read" with "readed" as that's what the database field is called.

### user_navigation.tpl
added a button to send a private message to the user's profile page.

### simple_messaging_main.php
changed the function name from GetMessege() to GetMessage() and you no longer need to be friends with a user to be able to send him a message.

Warning: apply these fixes at your own risk. Pligg's official team has not verified this yet.
The Pligg download points to 2.0 RC1 but I supposed there's a RC2 as per the announcement.
I'm using arabic on my Pligg and it's automatically RTL. All looks good so far except the comments area.

They don't look threaded. Please check attachments to understand what I'm trying to describe.

I changed the float of "comment-left" to right instead of left (comment2.png) but they still don't look threaded.

Any suggestions?
How do I send a private message? I installed "Simple Messaging" but I can't find the button to send a pm on the user's profile, even though we're both following each other.

Where is the button?

And why is it that when I visit a user's profile, it shows it as if it was my own profile. Saying that I HAVE x friends while in fact I'm on a friend's profile page not mine.
I just purchased 2 new modules and uploaded them to /modules/ but I still can't see them in the admin panel to enable them.

I went to both tabs; installed and uninstalled. No good.
I'm trying to change the background color of the submitter on link_summary.tpl
but so far it's not working

I'm using this

{if $user_level eq 'admin'}
{$link_submitter}{else}{$link_submitter}
{/if}
I have purchased two modules, but I didn't get any link to download them or any Zip files on my mail.
Below are the details of the modules:
(1) http://pligg.com/downloads/module/auto-content-scraper-2/
(2)http://pligg.com/downloads/module/facebook-sharer/
I just purchased google sitemap module.
Uploaded sitemap.php and sitemap.xsl to my root folder, chmoded them both 644

You can view sitemap here: http://maghnatis.com/sitemap.php

But when I add it to google, I get the following error.

We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

Example: URL restricted by robots.txt