Navigation

Pligg Support

when i try to run import.php

loading more than 3 minutes and getting 500 internal server error

host provider saying frequently hitting high memory

and my vps configuration have 512 mb ram

20 gb 1tb bandwidth


also i have added morethan 250 feeds to that website

Possible Answers

    The answer should be self explanatory. Each time you click import it's trying to grab approximately 2,500 stories to be submitted at the same time. It's obviously too much for your little VPS to handle.

    | Posted 125 days ago | Permalink | Hide Replies

    the issue is not with the server it's the script, it's terrible once you get a few feed son here the load is just ridiculous....

    | Posted 19 days ago | Permalink | Hide Replies

    I didn't think the memory upgrade would help!

    What I saw there looks to be a real mess like you went from a server using addon domains to one that actually uses separate accounts and points domains that way.

    When I tried to register, the register seemed to fail but when I retried it seemed to recognize me and declined the registration as it should if I already am registered. Yet I couldn't login.

    I also tried to run a RSS import from the browser but it never returned. I'm thinking you have Pligg installs under Pligg installs in subdirectories and those are running yet possibly not updating a database anywhere or updating the wrong database.

    You need more help to fix it than I think I can give you. Maybe it's time to 'redo from start' or at least run the installer on what you do have. And start out with a fresh new htaccess from the distro in the pligg installs.

    You also need to install an index file in the server root directory. ASAP!

    One thing I couldn't see was your control panel. What panel are you running? CPanel?

    Anyway, keep the backups or whatever you have from the old server somewhere safe. I'll be around tomorrow for a bit then back Thursday night. Gone Friday unless things change but I'll be back Sat. and Sun. maybe I can help you then.

    Are you sure you can't just get the suspension lifted at Hostgator or where ever that was?

    | Posted 124 days ago | Permalink | Hide Replies

    also upgraded to ram 512 to 1gb but getting same problem may be name server issues pointed a record 4 days ago

    ok will try on another pligg site on my website

    | Posted 125 days ago | Permalink | Hide Replies

    presently i redirected to domain to another temporary and i removed that you can check my website how slow it loading i rtied submit a story its showing blank page

    sometime when i enable url 2 mehtod getting .index.php/not on the server also i renamed .htacess as same

    http://bookmarks.indiagoesonline.com/

    | Posted 125 days ago | Permalink | Hide Replies

    also i tried to import individual that's also not working

    now i am upgrading to 1gb memory is this ok for memory

    or any optimization i need also i need what is the ram capacity of shared server of popular hosting companies like host gator

    the website worked fine on shared host gator but temporally suspended due to spammer attack to smf forum

    | Posted 125 days ago | Permalink | Hide Replies

    Didn't realize this was a running site move. Dang spammers!!

    I really can't see where the lack of memory is the problem but more memory might help overall.

    Worries me that individual feeds won't run. Can you post a simple new test message to the site?

    | Posted 125 days ago | Permalink | Hide Replies

    You're RSS run probably occurs as intended. At least partially. Apache just gets tired of waiting on it to finish. So you see a 500 error page. Though your server is small compared to some I'd still expect it to handle these feeds.

    I can think of a few fixes maybe if you get a incomplete run.

    First, Get rid of as many as you can. Set the feed frequency to zero or way out for those items, 72 hours or more.

    Watch for fetches from very slow to respond sites. Stagger them by using the feed frequency numbers.

    Run them with lower fetch numbers (try fetching just one feed item at a time but run fetches more often). The fetch is still the same size but the time to process one item is faster than several items.

    Set 'Feed URL Dupes' and 'Feed Title Dupes' to zero. Saves processing time!

    Run several items by themselves at first by launching a fetch from the individual RSS item setup.

    You probably have all the RSS feeds set to the same time span. Stagger the time spam. Set the first to 1 hour and add a hour to each consecutive item up to 23 hours (or even 47 hours). Start over adding hours on the next one after that.

    Run a few bigger ones by hand at first. Again from the RSS setup page.

    Use something to aggregate some feeds. A second Pligg instance, sub site or a WordPress Blog.

    If you have found 250 relevant RSS feeds just maybe you've found a niche in there that could use a site of it's own. Another Pligg or WordPress site that then serves as an aggregator to feed to your present site.

    Finally use cron to pull feeds every ten minutes even though the individual fetches are set an hour apart.

    The individual fetches you ran by hand will give you a running start against the cron triggered fetches.

    Do run the 'fetch all feeds' by hand once a week or so just to watch for issues. The last item fetched should be the last in your feeds list and should show you the 'time to next run' and the 'run anyway' button. You can learn a lot by watching a RSS run all the way through.

    I hesitate to mention this as this project is not Pligg 2.0 based yet (still runs 1.2.2) but I run http://www.FreakyVirginia.com in a Multi-Pligg configuration due to so much material there coming in via RSS. There's three sub-sites under the main site.

    Multi-Pligg is not supported by Pligg LLC. Here's a link to the Multi-Pligg info http://jeffhawkinswebsiteservices.com/

    | Posted 125 days ago | Permalink | Hide Replies

Who Upvoted this Story

Who Downvoted this Story