Navigation

Pligg Support

I just installed Pligg and this problem is still there.

I set the default language to be arabic, when logged out, it's in arabic. When I register a new username it flips back to English. When I goto my profile settings and choose arabic, click save, it's still in English.

Please fix this problem. It's a priority!

Possible Answers

    When you are logged in to an account, it loads the language file set by your profile settings. Visit your profile settings page and under the "Display Settings" area there should be a Language option with a dropdown list of available languages.

    I'm not sure if this would solve this problem, but perhaps if removed or renamed any of the language files that you are not using (ex. /languages/lang_english.conf) it will remove them from that list and maybe prevent this from happening with other user accounts.

    We need to look into how Pligg sets the local user's language in the profile settings area. It should default to whatever the main site language file is, but it could be defaulting to English right now.

    | Posted 274 days ago | Permalink | Hide Replies

    I have already gone into my profile settings page and selected a different language but it's not working. It keeps displaying English.

    I tried renaming lang_eng.conf to lang_eng.conf.default but the site stopped loading altogether saying it needs the english language.

    The language file /languages/lang_english.conf does not exist. Either this file is missing or you did not rename lang.conf after an upgrade. Try renaming /languages/lang.conf to /languages/lang_english.conf.

    If you wanna check it please goto http://beirut5ampere.org/maghnatis/ />
    I want the default language to be arabic and I'd like to have arabic language when a new user joins in.

    | Posted 274 days ago | Permalink | Hide Replies

    The quickest fix for you would be to just change the contents of the /languages/lang_english.conf file so that it contains the Arabic language file.

    That trick will have to do until we have a developer look into the issue. I'll assign this issue as a bug on GitHub's issue tracker page. Thanks for already starting a bug report on there: https://github.com/Pligg/pligg-cms/issues/8

    | Posted 274 days ago | Permalink | Hide Replies

    Thank you for your reply.

    I have tried your trick, it seems to work for now.

    I will also look into this myself as we are looking to expand pligg.

    | Posted 274 days ago | Permalink | Hide Replies

Who Upvoted this Story