Navigation

Pligg Support

I noticed that your .htaccess file already has redirect codes.
How do I configure this to my SSL's HTTPS protocol?

This is the code I was given to place in my .htaccess file:

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://VARIABLEDOMAIN.com/$1 [R=301,L]

But I notice in the Pligg .htaccess file there is a complex system of RewriteCond's and Rules.
Also, when I did this before I place this code, and then in settings.php I changed HTTP to HTTPS, and was able to be fully secured, but my Admin panel went all wonky into permanent edit mode.
I tested this in Pligg 2.0 and the same thing happens, but actually worse in appearance.

I would like to do this as clean as possible, so that everything works properly.
Please help?

Thanks,

Ivan

Possible Answers

    Sorted this out via our chat room with the user.

    The simple answer to enable https for your Pligg CMS site, is that you will need to edit your "Location Installed" information. This has to be done in 2 places: the Admin Settings area and your settings.php file (in that order).

    First navigate to your Admin Panel and click on the "Location Installed" link under the Settings sidebar area. Click on the Base URL value and set it to "https://YOUR-DOMAIN.COM", then save the input field. See the attached image for an example.

    Next open your /settings.php file. This file should have been updated by your last change, but sometimes takes a while to update so we recommend manually editing it. Change the $my_base_url value so that it matches the value set in the last paragraph.

    Once you have applied these two changes, your Pligg site should always request the https:// version of the domain.

    | Posted 267 days ago | Permalink | Hide Replies

    I have followed the information above to some degree as I do believe it is a little dated. The setting for location installed in Admin Panel is changed to https:// Also the setting file is at https:// and the .htaccess (which is only 4 short lines in version 2.0.1) is also https:// but I am still getting a warning in my Chrome Browser that states

    'This site contains script from unauthenicated sources'

    Any ideas?

    | Posted 80 days ago | Permalink | Hide Replies

    Re-sorted this out via chat room with Yankidank. I spoke too soon earlier.

    So to clarify: changing the Base URL variable under the "Location Installed" tab of the Admin backend from HTTP to HTTPS actually does change the settings.php automatically from I could tell.

    The next step is replacing your code from line 1 to roughly line 29 (based on your spacing) in your .htaccess file of your root to the contents of this pastebin file:

    http://pastebin.com/7YCPCFdj

    -

    Copy and Paste will do fine, but you can also use the WinMerge program found in the blogs section to compare differences in code if you'd like.

    Thanks again, Yankidank! This is a Lifesaver! :D

    Blessings!

    Ivan

    | Posted 267 days ago | Permalink | Hide Replies

    Can someone please answer this question?

    This seems like something that should be stickied.....

    | Posted 267 days ago | Permalink | Hide Replies

Who Upvoted this Story