Navigation

Pligg Support

I have a website;
example.com

I want to add pligg to this existing site in a subdomain with SEO fiendly URLS
example.com/bookmarks/

I have played around with admin options and .htaccess, still can't get it to work.

Frustrated, Any help?

Possible Answers

    I finally got it to work. Yes its the .htaccess file. I changed the file, some of the changes weren't 100% clear so I played around a bit until I got it right. If anyone needs a copy of my .htaccess file, I would be glad to share it to avoid any frustration.

    | Posted 84 days ago | Permalink | Hide Replies

    Sub Domain? Or Sub Directory?

    | Posted 84 days ago | Permalink | Hide Replies

    You have to modify the .htaccess file to reflect the name of the subfolder where your Pligg is installed. You can read on the comments of the .htaccess file where will you put the subfolder name.

    | Posted 84 days ago | Permalink | Hide Replies

    spoke too soon, site is broken after changing some "submit" options.

    I keep getting example.com/bookmarks/bookmarks/

    The sub directory is doubling up, where did I go wrong?? Help please.

    | Posted 84 days ago | Permalink | Hide Replies

    SEO friendly URLs do help somewhat but I never get too excited about SEO methods. If your URLs don't work then SEO didn't help you much.

    For the most part 'Settings.php' is for getting Pligg to work within your chosen directory structure while htaccess is for tweaking the URLS.

    So if your Install is basically working but the Stories, Etc. aren't showing up at their given URL then I'd concentrate on the htaccess file. That is where the web server builds or Rewrites the URLs for the SEO methods.

    | Posted 84 days ago | Permalink | Hide Replies

    Yes Sub Directory I guess, not sub domain. Will attempt this again today, unfortunately I'm getting conflicting answers here, one says .htacess, another person says settings.php, thats where im getting frustrated.

    In order for pligg to work with SEO urls in a subdirectory, what exactly do I need to do?

    | Posted 84 days ago | Permalink | Hide Replies

    Do you tried editing settings.php?

    $my_base_url = 'yourfullsite/bookmark';

    $my_pligg_base = '/bookmark/';

    Also, is necessarily delete your local cache in your browser. Is a good idea look into your tables by phpmyadmin at pligg_config if the path is Location Installed is correct. You can try anyway with NON SEO option.

    | Posted 84 days ago | Permalink | Hide Replies

Who Upvoted this Story