Navigation

Pligg Support

Is important to know how, because someone is trolling and sending requests to recover password many times.
Hello,

I'm wondering if there is a way for an administrator to set the time that new links are published?


Is this possible with any of the existing modules or templates? Or might I need to figure this out on my own?

Appreciate any insight you may have,

Thanks!

Nick
I have the latest version of pligg and use the default theme. I'd like to change the color of the register button, and only that button.
I assume I will have to make a new class for the register button and then edit the css accordingly. However, I'm not sure which css file I'll need to add this too, or which file I would find the individual button on which I can add the class.
If anyone can steer me in the right direction, thank you.
I'm getting ready to try installing the WordPress login plugin / Pligg module again. Hoping to get it working this time.

One caveat is I'm running WordPress in the root directory with Pligg answering from it's own directory via a htaccess redirect. Had to do it this way as some of my sites require WordPress running under multi-site.

I need to know the Pligg 'Salt_Length' and any other tips would be appreciated. If I get it working I'll try to document everything and make that available to everyone who needs it.

I also want to get it working with my older sites running 1.2.2 but the site I'm going to put this on runs 2.0.x.
** ATTENTION YANKIDANK **
I committed it on my forked pligg too.
**
table_tags and table_tag_cache are updated in two cases:

1. Upon submitting a new story.
2. Every time a story is edited.

In the first case, in \submit.php, LINE 428, we find a call to a function in the \libs\tags.php file: tags_insert_string($linkres->id, $dblang, $linkres->tags);

However, at this stage the status of the story being submitted is still ‘discard’, while in the Function tags_insert_string, it specifically selects from table_links only the links that meet the status of published or new, therefore the new tags entered for story being submitted won’t be included and won’t appear in the tag cloud until the next submit (and again the newest tags won’t be included) or when the admin deletes the discarded stories from the admin section and automatically rebuilds the table_tag_cache.

After following the logic of the process, the best place to call the Function tags_insert_string is after we make sure that the story’s status is set to publish:

1. In \submit.php, LINE 428, comment or remove this code:

tags_insert_string($linkres->id, $dblang, $linkres->tags);

2. On LINE 517, after
function do_submit3() {

change this: global $db;

To this: global $db, $dblang;

Because we need the database language for the table_tags entries

3. On LINE 549, right after:

$linkres->check_should_publish();

Add this (the code we commented or removed in step 1)

tags_insert_string(
I did a file comparison between the Pligg CMS available from the download section (2.0.2) and the masters files from github (https://github.com/Pligg/pligg-cms/archive/39944ed20275cea802c266b4969881af7310ba01.zip)

Users, who still have the 2.0.2 from the download and did not perform the fixes updates from the github master, need to integrate the following fixes that deal with issues and addresses a lot of questions that are posted with regard to stories and their management!

To fix the search for subcategories:
1- When you select a category from the advanced search page, it will not return results from that category and all sub-categories belonging to it
https://github.com/Pligg/pligg-cms/commit/39944ed20275cea802c266b4969881af7310ba01

2- Fix applied to fix the "Show subcategories" feature in Admin > Config > Miscellaneous. Advanced search is still not able to search both main categories and subcategories belonging to them, it will only return results from the selected category
https://github.com/Pligg/pligg-cms/commit/2fcf3bac73246ca27de9e9f23f865153632fe4aa

Fix to the Spam trigger module
1- https://github.com/Pligg/pligg-cms/commit/2faf855793814f82d7c61a8745a93998c13967e0

Fix to the Negative votes to discard a story
1- https://github.com/Pligg/pligg-cms/commit/d05ccab49c8efbc7b0ba69b2ad6e96056652296b

Fix an issue where administrators are unable to use the "Edit Group"
https://github.com/Pligg/pligg-cms/commit/699b881df643561fe2d7eab9d179a0255e5b1567
I want to get the PowerTools for Pligg CMS and Facebook Module. For the latter it mentions that it is Designed for Pligg CMS 2.0.2. How about the Power Tools?

Thank you!
As there is no DELETE user function in Pligg, I used KillSpam User function on two test accounts.

Unfortunately, this action has BLOCKED my IP, and I cannot create new users form my IP address now.

Q: How to unblock my IP?

Thanks!
In \libs\link.php, Function store_basic() LINE 200, I noticed that link_published_date is set to 943941600 Unix timestamp which translates to 1999-11-30 01:00:00

Unless there is another reason I am not getting, I believe that this line of code:

if($this->published_date == 0){$this->published_date = 943941600;}

Should be modified to:

if($this->published_date == 0){$this->published_date = $this->date;}

This way the published date is set automatically to the link date when submitted.
Hi!
I recently create a new Pligg site. When I try to log into it, it just keeps loading and never gives me a page. I have tried reinstalling and using the build in auto installer. Interestingly, when I create a new user, it logs me in and works fine.
I really need help.
Flynn
PS, site is http://launchdeck.net/