Navigation

Pligg Support

The Statistics Widget was returning "UNKNOWN" for the MySql version. To fix it:
Open /widgets/statistics/templates/widget.tpl
On LINE 138, delete this bloc of code between the {php} and {/php}. It is returning an empty array:
function find_SQL_Version() {
$output = shell_exec('mysql -V');
preg_match('@[0-9]+.[0-9]+.[0-9]+@', $output, $version);
if ($version[0] != ''){
return $version[0];
}else{
return 'Unknown';
}
}
echo find_SQL_Version();

Replace it with the following block, between the {php} and {/php}
$link = mysqli_connect(localhost,EZSQL_DB_USER,EZSQL_DB_PASSWORD);
/* check connection */
if (mysqli_connect_errno()) {
printf("Connect failed: %sn", mysqli_connect_error());
exit();
}
$my_sql = mysqli_get_server_info($link);
//$my_sql returns will be something like the version and -log (5.5.24-log). we have to just grab the version number
$my_sql_version = substr($my_sql, 0, strpos($my_sql, "-"));
echo $my_sql_version;
mysqli_close($link);

https://github.com/redwinefireplace/pligg-cms/commit/f5093812849ef56bc7c3b8c34e97e63f06767a25
please how can I change the blue pligg header to green. I want my site to have a green look, but i like the theme, just want to change the color.
please its kinda urgent, thanks
When adding comments to a story containing a word within the Light Trigger list the comment is not moderated. When using a word from the Medium Trigger, it is not discarded or moderated. I have not tested the Hard Trigger. Has anyone noticed this?
I use Facebook Module v 4.7. After signning in to a pligg website using Facebook popup window, authentication works fine, but the redirect http://domain.com/modules/fb/login.php shows a blank page (instead of the form in the fb_step2.tpl). Could you please give me your comments about this problem? thanks
Hi There,

Plese help me, How to add new posting on homepage? why on homepage only show "welcome install notification" ?

Thanks.
http://www.squidbookmark.com
Hi,

How do you get support for the 3rd party products sold on this site? There is no way to submit a support request on the product page. It would also be helpful to be able to rate the product. Note: This pertains to the 'Template' section'.
Hello, my pligg admin settings are not saving.
Hello
I just installed pligg 2.0.0rc2 on my host (Bluehost). Everything looks great, but after changing "Require users to validate their email address?" to "true", I noticed that no validation email is being sent after registration.

please assist
Hi,
I want to know if it's possible to show larger thumbnails on one page than another, this is so links under picture category can be seen better.

I just need the code that controls the thumbnail size created by the upload module.
Thanks
Hello,
When registering a new user using the facebook module, I get an infinite redirect error. It contacts my facebook app correct, I can login to facebook in the popup dialog, authorise information retrieval and sharing etc, but when I submit it just bounces back and forth between facebook and fb.php.

I've created the app correct in facebook, and i've installed the facebook module (fb) in pligg and configured correctly with the keys.

site url: http://news.hyperlingo.com

Please could you help me solve this issue?
Thanks
Carl